What’s Vulnerable › Vulnerabilities
CVE-2025-8427: Beaver Builder Plugin (Starter Version) <= 2.9.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'auto_play'
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-10-08
- Weakness: CWE-79
Description
The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘auto_play’ parameter in all versions up to, and including, 2.9.2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- beaverbuilder Beaver Builder Page Builder – Drag and Drop Website Builder: before 2.9.3.1 — fixed in 2.9.3.1
How to fix
Upgrade to a fixed version: beaverbuilder Beaver Builder Page Builder – Drag and Drop Website Builder 2.9.3.1. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/afec9b5b-da37-4e12-935e-9d3bb3ca01f0?source=cve
- https://www.wpbeaverbuilder.com/change-logs/
Get alerted when CVE-2025-8427 or the next vulnerability affects your stack