What’s Vulnerable › Vulnerabilities
CVE-2025-8447: Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed read-only access
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-26 · updated 2026-06-17
- Weakness: CWE-639
Description
An improper access control vulnerability was identified in GitHub Enterprise Server that allowed users with access to any repository to retrieve limited code content from another repository by creating a diff between the repositories. To exploit this vulnerability, an attacker needed to know the name of a private repository along with its branches, tags, or commit SHAs that they could use to trigger compare/diff functionality and retrieve limited code without proper authorization. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18, and was fixed in versions 3.14.17, 3.15.12, 3.16.8 and 3.17.5. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: before 3.14.17; from 3.15.0 before 3.15.12; from 3.16.0 before 3.16.8; from 3.17.0 before 3.17.5 — fixed in 3.14.17, 3.15.12, 3.16.8, 3.17.5
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.14.17, 3.15.12, 3.16.8, 3.17.5. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.17
- https://docs.github.com/en/enterprise-server@3.15/admin/release-notes#3.15.12
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.8
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.5
Get alerted when CVE-2025-8447 or the next vulnerability affects your stack