What’s Vulnerable › Vulnerabilities
CVE-2025-8521: givanz Vvveb Add Type post-types cross site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-04 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability, which was classified as problematic, has been found in givanz Vvveb up to 1.0.5. This issue affects some unknown processing of the file /vadmin123/index.php?module=settings/post-types of the component Add Type Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.6 is able to address this issue. The patch is named b53c7161da606f512b7efcb392d6ffc708688d49/605a70f8729e4d44ebe272671cb1e43e3d6ae014. It is recommended to upgrade the affected component.
Affected products
- givanz Vvveb: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: givanz Vvveb 1.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/givanz/Vvveb/commit/b53c7161da606f512b7efcb392d6ffc708688d49
- https://github.com/givanz/Vvveb/releases/tag/1.0.6
- https://hkohi.ca/vulnerability/11
- https://vuldb.com/?ctiid.318647
- https://vuldb.com/?id.318647
- https://vuldb.com/?submit.625003
- https://hkohi.ca/vulnerability/11
- https://vuldb.com/?submit.625003
Get alerted when CVE-2025-8521 or the next vulnerability affects your stack