What’s Vulnerable › Vulnerabilities
CVE-2025-8591: Reflected Cross-Site Scripting via URL Parameter in Multiple WSO2 Products Enables UI Modification
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-06 · updated 2026-10-06
- Weakness: CWE-79
Description
The software accepts user-supplied input via a URL parameter without adequate output encoding before reflecting it back to the user's browser. This condition allows an attacker to inject malicious script content into pages served by the application. By leveraging this weakness, an attacker can cause the user's browser to redirect to a malicious website, modify the UI of the webpage, or retrieve information from the browser. However, the impact is mitigated by the use of httpOnly flags on session-related cookies, preventing session hijacking.
Affected products
- WSO2 Api Control Plane: from 4.5.0 before 4.5.0.44; from 4.6.0 before 4.6.0.8 — fixed in 4.5.0.44, 4.6.0.8
- WSO2 API Manager: from 3.1.0 before 3.1.0.355; from 3.2.0 before 3.2.0.459; from 3.2.1 before 3.2.1.78; from 4.0.0 before 4.0.0.380; from 4.1.0 before 4.1.0.243; from 4.2.0 before 4.2.0.183 — fixed in 3.1.0.355, 3.2.0.459, 3.2.1.78, 4.0.0.380, 4.1.0.243, 4.2.0.183
- WSO2 Identity Server: from 5.10.0 before 5.10.0.384; from 6.0.0 before 6.0.0.255; from 7.0.0 before 7.0.0.131; from 7.1.0 before 7.1.0.51 — fixed in 5.10.0.384, 6.0.0.255, 7.0.0.131, 7.1.0.51
- WSO2 Identity Server As Key Manager: from 5.10.0 before 5.10.0.375 — fixed in 5.10.0.375
- WSO2 Open Banking Am: from 2.0.0 before 2.0.0.404 — fixed in 2.0.0.404
- WSO2 Open Banking Iam: from 2.0.0 before 2.0.0.424 — fixed in 2.0.0.424
- WSO2 Traffic Manager: from 4.5.0 before 4.5.0.42; from 4.6.0 before 4.6.0.7 — fixed in 4.5.0.42, 4.6.0.7
- WSO2 Universal Gateway: from 4.5.0 before 4.5.0.42; from 4.6.0 before 4.6.0.7 — fixed in 4.5.0.42, 4.6.0.7
How to fix
Upgrade to a fixed version: WSO2 Api Control Plane 4.5.0.44, 4.6.0.8; WSO2 API Manager 3.1.0.355, 3.2.0.459, 3.2.1.78, 4.0.0.380; WSO2 Identity Server 5.10.0.384, 6.0.0.255, 7.0.0.131, 7.1.0.51; WSO2 Identity Server As Key Manager 5.10.0.375; WSO2 Open Banking Am 2.0.0.404; WSO2 Open Banking Iam 2.0.0.424; WSO2 Traffic Manager 4.5.0.42, 4.6.0.7; WSO2 Universal Gateway 4.5.0.42, 4.6.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8591 or the next vulnerability affects your stack