What’s Vulnerable › Vulnerabilities
CVE-2025-8681: Pega Platform versions 7.1.0 to Infinity 24.2.2 are affected by a Stored XSS issue in a user interface component
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-10 · updated 2026-09-26
- Weakness: CWE-79
Description
Pega Platform versions 7.1.0 to Infinity 24.2.2 are affected by a Stored XSS issue in a user interface component. Requires a high privileged user with a developer role.
Affected products
- Pegasystems Pega Infinity: from 7.1.0 before 23.1.5; from 24.1.0 before 24.1.3; from 24.2.0 before 24.2.2 — fixed in 23.1.5, 24.1.3, 24.2.2
How to fix
Upgrade to a fixed version: Pegasystems Pega Infinity 23.1.5, 24.1.3, 24.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8681 or the next vulnerability affects your stack