What’s Vulnerable › Vulnerabilities
CVE-2025-8714: PostgreSQL pg_dump lets superuser of origin server execute arbitrary code in psql client
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-829
Description
Untrusted data inclusion in pg_dump in PostgreSQL allows a malicious superuser of the origin server to inject arbitrary code for restore-time execution as the client operating system account running psql to restore the dump, via psql meta-commands. pg_dumpall is also affected. pg_restore is affected when used to generate a plain-format dump. This is similar to MySQL CVE-2024-21096. Versions before PostgreSQL 17.6, 16.10, 15.14, 14.19, and 13.22 are affected.
Affected products
- PostgreSQL: from 17 before 17.6; from 16 before 16.10; from 15 before 15.14; from 14 before 14.19; before 13.22 — fixed in 13.22, 14.19, 15.14, 16.10, 17.6
How to fix
Upgrade to a fixed version: PostgreSQL 13.22, 14.19, 15.14, 16.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8714 or the next vulnerability affects your stack