What’s Vulnerable › Vulnerabilities
CVE-2025-8715: PostgreSQL pg_dump newline in object name executes arbitrary code in psql client and in restore target server
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-93
Description
Improper neutralization of newlines in pg_dump in PostgreSQL allows a user of the origin server to inject arbitrary code for restore-time execution as the client operating system account running psql to restore the dump, via psql meta-commands inside a purpose-crafted object name. The same attacks can achieve SQL injection as a superuser of the restore target server. pg_dumpall, pg_restore, and pg_upgrade are also affected. Versions before PostgreSQL 17.6, 16.10, 15.14, 14.19, and 13.22 are affected. Versions before 11.20 are unaffected. CVE-2012-0868 had fixed this class of problem, but version 11.20 reintroduced it.
Affected products
- PostgreSQL: from 17 before 17.6; from 16 before 16.10; from 15 before 15.14; from 14 before 14.19; from 11.20 before 13.22 — fixed in 13.22, 14.19, 15.14, 16.10, 17.6
How to fix
Upgrade to a fixed version: PostgreSQL 13.22, 14.19, 15.14, 16.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8715 or the next vulnerability affects your stack