What’s Vulnerable › Vulnerabilities
CVE-2025-8799: Open5GS AMF npcf-build.c amf_nsmf_pdusession_build_create_sm_context denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-10 · updated 2026-06-17
- Weakness: CWE-404
Description
A vulnerability was identified in Open5GS up to 2.7.5. Affected by this vulnerability is the function amf_npcf_am_policy_control_build_create/amf_nsmf_pdusession_build_create_sm_context of the file src/amf/npcf-build.c of the component AMF. The manipulation leads to denial of service. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.7.6 is able to address this issue. The patch is named cf63dd63197bf61a4b041aa364ba6a6199ab15e4. It is recommended to upgrade the affected component.
Affected products
- Open5GS: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: Open5GS 2.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/ZHENGHAOHELLO/BugReport/blob/main/CVE-2025-8799
- https://github.com/open5gs/open5gs/commit/cf63dd63197bf61a4b041aa364ba6a6199ab15e4
- https://github.com/open5gs/open5gs/issues/3979
- https://github.com/open5gs/open5gs/issues/3979#issuecomment-3054369376
- https://github.com/open5gs/open5gs/releases/tag/v2.7.6
- https://github.com/user-attachments/files/21104682/5g_amf_crash_ran.zip
- https://vuldb.com/?ctiid.319327
- https://vuldb.com/?id.319327
- https://vuldb.com/?submit.626112
- https://github.com/open5gs/open5gs/issues/3979
Get alerted when CVE-2025-8799 or the next vulnerability affects your stack