What’s Vulnerable › Vulnerabilities
CVE-2025-8800: Open5GS AMF esm-handler.c esm_handle_pdn_connectivity_request denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-10 · updated 2026-06-17
- Weakness: CWE-404
Description
A vulnerability has been found in Open5GS up to 2.7.5. Affected by this issue is the function esm_handle_pdn_connectivity_request of the file src/mme/esm-handler.c of the component AMF Component. The manipulation leads to denial of service. The attack may be launched remotely. Upgrading to version 2.7.6 is able to address this issue. The name of the patch is 701505102f514cbde2856cd2ebc9bedb7efc820d. It is recommended to upgrade the affected component.
Affected products
- Open5GS: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: Open5GS 2.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/ZHENGHAOHELLO/BugReport/blob/main/CVE-2025-8800
- https://github.com/open5gs/open5gs/commit/701505102f514cbde2856cd2ebc9bedb7efc820d
- https://github.com/open5gs/open5gs/issues/3980
- https://github.com/open5gs/open5gs/issues/3980#issuecomment-3054894281
- https://github.com/open5gs/open5gs/releases/tag/v2.7.6
- https://vuldb.com/?ctiid.319328
- https://vuldb.com/?id.319328
- https://vuldb.com/?submit.626113
- https://github.com/open5gs/open5gs/issues/3980
Get alerted when CVE-2025-8800 or the next vulnerability affects your stack