What’s Vulnerable › Vulnerabilities
CVE-2025-8863
- Severity: high (CVSS 7.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-11 · updated 2026-06-17
- Weakness: CWE-319
Description
YugabyteDB diagnostic information was transmitted over HTTP, which could expose sensitive data during transmission
Affected products
- YugabyteDB Inc YugabyteDB: from 2024.1.0 before 2024.1.3; from 2.20.0.0 before 2.20.7.0; from 2.23.0.0 before 2.23.1.0 — fixed in 2.20.7.0, 2.23.1.0, 2024.1.3
How to fix
Upgrade to a fixed version: YugabyteDB Inc YugabyteDB 2.20.7.0, 2.23.1.0, 2024.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8863 or the next vulnerability affects your stack