What’s Vulnerable › Vulnerabilities
CVE-2025-8869: Fallback tar extraction in pip doesn't check symbolic links point to extraction directory
- Severity: medium (CVSS 5.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-24 · updated 2026-09-26
Description
When extracting a tar archive pip may not check symbolic links point into the extraction directory if the tarfile module doesn't implement PEP 706. Note that upgrading pip to a "fixed" version for this vulnerability doesn't fix all known vulnerabilities that are remediated by using a Python version that implements PEP 706. Note that this is a vulnerability in pip's fallback implementation of tar extraction for Python versions that don't implement PEP 706 and therefore are not secure to all vulnerabilities in the Python 'tarfile' module. If you're using a Python version that implements PEP 706 then pip doesn't use the "vulnerable" fallback code. Mitigations include upgrading to a version of pip that includes the fix, upgrading to a Python version that implements PEP 706 (Python >=3.9.17, >=3.10.12, >=3.11.4, or >=3.12), applying the linked patch, or inspecting source distributions (sdists) before installation as is already a best-practice.
Affected products
- Pypi Pip: before 25.3; 0.2, 0.2.1, 0.3, 0.3.1, 0.4, 0.5 (+145) — fixed in 25.3
- Python Packaging Authority pip: before 25.3 — fixed in 25.3
How to fix
Upgrade to a fixed version: Pypi Pip 25.3; Python Packaging Authority pip 25.3. Check the vendor advisory for mitigations.
References
- https://github.com/pypa/pip/pull/13550
- https://mail.python.org/archives/list/security-announce@python.org/thread/IF5A3GCJY3VH7BVHJKOWOJFKTW7VFQEN/
- https://lists.debian.org/debian-lts-announce/2025/10/msg00028.html
Get alerted when CVE-2025-8869 or the next vulnerability affects your stack