What’s Vulnerable › Vulnerabilities
CVE-2025-9079: Admin RCE via prepackaged plugins by way of misconfigured imports directory
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-19 · updated 2026-10-19
- Weakness: CWE-22
Description
Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to validate import directory path configuration which allows admin users to execute arbitrary code via malicious plugin upload to prepackaged plugins directory
Affected products
- Mattermost: from 9.11.0 before 9.11.18; from 10.5.0 before 10.5.9; from 10.8.0 before 10.8.4; from 10.9.0 before 10.9.4; from 10.10.0 before 10.10.2 — fixed in 10.10.2, 10.5.9, 10.8.4, 10.9.4, 9.11.18
How to fix
Upgrade to a fixed version: Mattermost 10.10.2, 10.5.9, 10.8.4, 10.9.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-9079 or the next vulnerability affects your stack