What’s Vulnerable › Vulnerabilities
CVE-2025-9083: Ninja-forms < 3.11.1 - Unauthenticated PHP Objection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-18 · updated 2026-06-17
- Weakness: CWE-502
Description
The Ninja Forms WordPress plugin before 3.11.1 unserializes user input via form field, which could allow Unauthenticated users to perform PHP Object Injection when a suitable gadget is present on the blog.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.11.1 — fixed in 3.11.1
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.11.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/60b4d7fc-5d23-4dcf-bd7f-e202cabc2625/
- https://wpscan.com/vulnerability/60b4d7fc-5d23-4dcf-bd7f-e202cabc2625/
Get alerted when CVE-2025-9083 or the next vulnerability affects your stack