What’s Vulnerable › Vulnerabilities
CVE-2025-9115: Etsy Shop < 3.0.7 - Reflected XSS via $_SERVER['REQUEST_URI']
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-22 · updated 2026-06-17
Description
The Etsy Shop WordPress plugin before 3.0.7 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers.
Affected products
- Etsy Shop: before 3.0.7 — fixed in 3.0.7
How to fix
Upgrade to a fixed version: Etsy Shop 3.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-9115 or the next vulnerability affects your stack