What’s Vulnerable › Vulnerabilities
CVE-2025-9161: Rockwell Automation FactoryTalk Optix Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-06-17
- Weakness: CWE-77
Description
A security issue exists within FactoryTalk Optix MQTT broker due to the lack of URI sanitization. This flaw enables the loading of remote Mosquito plugins, which can be used to achieve remote code execution.
Affected products
- Rockwell Automation FactoryTalk Optix: from 1.5.0 before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Rockwell Automation FactoryTalk Optix 1.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-9161 or the next vulnerability affects your stack