What’s Vulnerable › Vulnerabilities
CVE-2025-9185: Memory safety bugs fixed in Firefox ESR 115.27, Firefox ESR 128.14, Thunderbird ESR 128.14, Firefox ESR 140.2, Thunderbird ESR 140.2, Firefox 142 and Thunderbird 142
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-19 · updated 2026-10-05
- Weakness: CWE-119
Description
Memory safety bugs present in Firefox ESR 115.26, Firefox ESR 128.13, Thunderbird ESR 128.13, Firefox ESR 140.1, Thunderbird ESR 140.1, Firefox 141 and Thunderbird 141. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability was fixed in Firefox 142, Firefox ESR 115.27, Firefox ESR 128.14, Firefox ESR 140.2, Thunderbird 142, Thunderbird 128.14, and Thunderbird 140.2.
Affected products
- Mozilla Firefox: before 115.27.0; before 142.0; from 128.0 before 128.14.0; from 140.0 before 140.2.0 — fixed in 115.27.0, 128.14.0, 140.2.0, 142.0
- Mozilla Thunderbird: before 128.14.0; before 142.0; from 140.0 before 140.2.0 — fixed in 128.14.0, 140.2.0, 142.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 115.27.0, 128.14.0, 140.2.0, 142.0; Mozilla Thunderbird 128.14.0, 140.2.0, 142.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/buglist.cgi?bug_id=1970154%2C1976782%2C1977166
- https://www.mozilla.org/security/advisories/mfsa2025-64/
- https://www.mozilla.org/security/advisories/mfsa2025-65/
- https://www.mozilla.org/security/advisories/mfsa2025-66/
- https://www.mozilla.org/security/advisories/mfsa2025-67/
- https://www.mozilla.org/security/advisories/mfsa2025-70/
- https://www.mozilla.org/security/advisories/mfsa2025-71/
- https://www.mozilla.org/security/advisories/mfsa2025-72/
- https://lists.debian.org/debian-lts-announce/2025/08/msg00016.html
- https://lists.debian.org/debian-lts-announce/2025/08/msg00018.html
Get alerted when CVE-2025-9185 or the next vulnerability affects your stack