What’s Vulnerable › Vulnerabilities

CVE-2025-9222: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2.2 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1 that could have allowed an authenticated user to achieve stored cross-site scripting by exploiting GitLab Flavored Markdown.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.5.5, 18.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-9222 or the next vulnerability affects your stack