What’s Vulnerable › Vulnerabilities
CVE-2025-9294: Quiz And Survey Master <= 10.3.1 - Missing Authorization to Authenticated (Subscriber+) Quiz Results Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-06 · updated 2026-10-07
- Weakness: CWE-285
Description
The Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the qsm_dashboard_delete_result function in all versions up to, and including, 10.3.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete quiz results.
Affected products
- ExpressTech Quiz And Survey Master: before 10.3.2 — fixed in 10.3.2
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 10.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/quiz-master-next/tags/10.2.6/php/admin/options-page-questions-tab.php#L1116
- https://research.cleantalk.org/cve-2025-9294/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/55895508-d0ef-4855-8d15-b8a45ba0dcb2?source=cve
Get alerted when CVE-2025-9294 or the next vulnerability affects your stack