What’s Vulnerable › Vulnerabilities
CVE-2025-9323: Foxit PDF Reader JP2 File Parsing Out-Of-Bounds Read Information Disclosure Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-02 · updated 2026-06-17
- Weakness: CWE-125
Description
Foxit PDF Reader JP2 File Parsing Out-Of-Bounds Read Information Disclosure Vulnerability. This vulnerability allows remote attackers to disclose sensitive information on affected installations of Foxit PDF Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of JP2 files. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated object. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of the current process. Was ZDI-CAN-27101.
Affected products
- Foxit PDF Reader: through 13.1.7.23637; from 2023.1.0.15510 through 2023.3.0.23028; from 2024.1.0.23997 through 2024.4.1.27687; 2025.1.0.27937
- Foxit Pdf Reader: before 2025.1.0.27937 — fixed in 2025.1.0.27937
How to fix
Upgrade to a fixed version: Foxit Pdf Reader 2025.1.0.27937. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-25-869/
Get alerted when CVE-2025-9323 or the next vulnerability affects your stack