What’s Vulnerable › Vulnerabilities
CVE-2025-9353: Themify Builder <= 7.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-24 · updated 2026-09-26
- Weakness: CWE-79
Description
The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.
Affected products
- themifyme Themify Builder: through 7.6.9
References
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/js/editor/build/modules.min.js
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L73
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L96
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-icon.php#L95
- https://plugins.trac.wordpress.org/changeset/3355757/
- https://plugins.trac.wordpress.org/changeset/3366817/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/508e97a0-9757-426c-bf0f-cdce6b489ce7?source=cve
Get alerted when CVE-2025-9353 or the next vulnerability affects your stack