What’s Vulnerable › Vulnerabilities
CVE-2025-9390: vim xxd xxd.c main buffer overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-24 · updated 2026-06-17
- Weakness: CWE-119
Description
A security flaw has been discovered in vim up to 9.1.1615. Affected by this vulnerability is the function main of the file src/xxd/xxd.c of the component xxd. The manipulation results in buffer overflow. The attack requires a local approach. The exploit has been released to the public and may be exploited. Upgrading to version 9.1.1616 addresses this issue. The patch is identified as eeef7c77436a78cd27047b0f5fa6925d56de3cb0. It is recommended to upgrade the affected component.
Affected products
- vim/vim: from 9.1.1459 before 9.1.1616 — fixed in 9.1.1616
How to fix
Upgrade to a fixed version: vim/vim 9.1.1616. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1JLnqrdcGsjUhbYzIEweXIGZyETjHlKtX/view?usp=sharing
- https://github.com/vim/vim/commit/eeef7c77436a78cd27047b0f5fa6925d56de3cb0
- https://github.com/vim/vim/issues/17944
- https://github.com/vim/vim/pull/17947
- https://github.com/vim/vim/releases/tag/v9.1.1616
- https://vuldb.com/?ctiid.321223
- https://vuldb.com/?id.321223
- https://vuldb.com/?submit.630903
- https://github.com/vim/vim/issues/17944
- https://vuldb.com/?submit.630903
Get alerted when CVE-2025-9390 or the next vulnerability affects your stack