What’s Vulnerable › Vulnerabilities
CVE-2025-9501: W3 Total Cache < 2.8.13 - Unauthenticated Command Injection
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-17 · updated 2026-10-19
Description
The W3 Total Cache WordPress plugin before 2.8.13 is vulnerable to command injection via the _parse_dynamic_mfunc function, allowing unauthenticated users to execute PHP commands by submitting a comment with a malicious payload to a post.
Affected products
- W3 Total Cache: before 2.8.13 — fixed in 2.8.13
How to fix
Upgrade to a fixed version: W3 Total Cache 2.8.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-9501 or the next vulnerability affects your stack