What’s Vulnerable › Vulnerabilities
CVE-2025-9524
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-1287
Description
The VAPIX API port.cgi did not have sufficient input validation, which may result in process crashes and impact usability. This vulnerability can only be exploited after authenticating with a viewer- operator- or administrator-privileged service account.
Affected products
- Axis Communications AB AXIS OS: from 6.50.0 before 6.50.5.21; from 7.0.0 before 8.40.89; from 9.0.0 before 9.80.123; from 10.0.0 before 10.12.305; from 11.0.0 before 11.11.177; from 12.0.0 before 12.7.11 — fixed in 10.12.305, 11.11.177, 12.7.11, 6.50.5.21, 8.40.89, 9.80.123
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 10.12.305, 11.11.177, 12.7.11, 6.50.5.21. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-9524 or the next vulnerability affects your stack