What’s Vulnerable › Vulnerabilities
CVE-2025-9540: Markup Markdown < 3.20.10 - Contributor+ Stored XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-22 · updated 2026-06-17
Description
The Markup Markdown WordPress plugin before 3.20.10 allows links to contain JavaScript which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Markup Markdown: before 3.20.10 — fixed in 3.20.10
How to fix
Upgrade to a fixed version: Markup Markdown 3.20.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-9540 or the next vulnerability affects your stack