What’s Vulnerable › Vulnerabilities
CVE-2025-9551: Protected Pages - Moderately critical - Access bypass - SA-CONTRIB-2025-101
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-10 · updated 2026-10-08
- Weakness: CWE-307
Description
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Protected Pages allows Brute Force.This issue affects Protected Pages: from 0.0.0 before 1.8.0, from 7.X-1.0 before 7.X-2.5.
Affected products
- Drupal Protected Pages: before 8.x-1.8 — fixed in 8.x-1.8
How to fix
Upgrade to a fixed version: Drupal Protected Pages 8.x-1.8. Check the vendor advisory for mitigations.
References
- https://d7es.tag1.com/security-advisories/protected-pages-moderately-critical-access-bypass-sa-contrib-2025-101
- https://docs.herodevs.com/drupal/release-notes/protected-pages
- https://www.drupal.org/sa-contrib-2025-101
Get alerted when CVE-2025-9551 or the next vulnerability affects your stack