What’s Vulnerable › Vulnerabilities
CVE-2025-9559: Pega Platform versions 8.7.5 to Infinity 24.2.2 are affected by a Insecure Direct Object Reference issue in a user interface component that can only be used to read data
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-16 · updated 2026-10-09
- Weakness: CWE-639
Description
Pega Platform versions 8.7.5 to Infinity 24.2.2 are affected by a Insecure Direct Object Reference issue in a user interface component that can only be used to read data.
Affected products
- Pegasystems Pega Infinity: from 7.1.0 before 23.1.5; from 24.1.0 through 24.1.3; from 24.2.0 through 24.2.2 — fixed in 23.1.5
How to fix
Upgrade to a fixed version: Pegasystems Pega Infinity 23.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-9559 or the next vulnerability affects your stack