What’s Vulnerable › Vulnerabilities

CVE-2025-9624: OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS

Description

A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs. This issue affects all OpenSearch versions between 3.0.0 and < 3.3.0 and OpenSearch < 2.19.4.

Affected products

How to fix

Upgrade to a fixed version: AWS Opensearch 3.3.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-9624 or the next vulnerability affects your stack