What’s Vulnerable › Vulnerabilities
CVE-2025-9634: Plugin updates blocker <= 0.2 - Cross-Site Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-11 · updated 2026-06-17
- Weakness: CWE-352
Description
The Plugin updates blocker plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 0.2. This is due to missing or incorrect nonce validation on the pub_save action handler. This makes it possible for unauthenticated attackers to disable or enable plugin updates via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- jegerwan Plugin updates blocker: through 0.2
References
- https://plugins.trac.wordpress.org/browser/plugin-update-blocker/tags/0.2/dpu-menu.php#L3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6b66a0bc-9125-45ee-9583-bc503634a0ce?source=cve
Get alerted when CVE-2025-9634 or the next vulnerability affects your stack