What’s Vulnerable › Vulnerabilities

CVE-2025-9642: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 14.10 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1 that could allow an attacker to inject malicious content that may lead to account takeover.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.2.7, 18.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-9642 or the next vulnerability affects your stack