What’s Vulnerable › Vulnerabilities
CVE-2025-9796: thinkgem JeeSite EncodeUtils.java decodeUrl2 cross site scripting
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-01 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in thinkgem JeeSite up to 5.12.1. This affects the function decodeUrl2 of the file common/src/main/java/com/jeesite/common/codec/EncodeUtils.java. The manipulation results in cross site scripting. It is possible to launch the attack remotely. The exploit has been made public and could be used. Upgrading to version 5.13.0 mitigates this issue. The patch is identified as 63773c97a56bdb3649510e83b66c16db4754965b. Upgrading the affected component is recommended.
Affected products
- thinkgem JeeSite: before 5.13.0 — fixed in 5.13.0
How to fix
Upgrade to a fixed version: thinkgem JeeSite 5.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/thinkgem/jeesite5/commit/63773c97a56bdb3649510e83b66c16db4754965b
- https://github.com/thinkgem/jeesite5/issues/33
- https://github.com/thinkgem/jeesite5/issues/33#issue-3330107533
- https://github.com/thinkgem/jeesite5/issues/33#issuecomment-3197374560
- https://github.com/thinkgem/jeesite5/releases/tag/v5.13.0.springboo3
- https://vuldb.com/?ctiid.322111
- https://vuldb.com/?id.322111
- https://vuldb.com/?submit.641125
- https://github.com/thinkgem/jeesite5/issues/33
- https://github.com/thinkgem/jeesite5/issues/33#issue-3330107533
- https://github.com/thinkgem/jeesite5/issues/33#issuecomment-3197374560
Get alerted when CVE-2025-9796 or the next vulnerability affects your stack