What’s Vulnerable › Vulnerabilities
CVE-2025-9907: Event-driven-ansible: event stream test mode exposes sensitive headers in aap eda
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in the Red Hat Ansible Automation Platform, Event-Driven Ansible (EDA) Event Stream API. This vulnerability allows exposure of sensitive client credentials and internal infrastructure headers via the test_headers field when an event stream is in test mode. The possible outcome includes leakage of internal infrastructure details, accidental disclosure of user or system credentials, privilege escalation if high-value tokens are exposed, and persistent sensitive data exposure to all users with read access on the event stream.
Affected products
- Red Hat Ansible Automation Platform: before 2.6 — fixed in 2.6
- RedHat Ansible Developer: 1.2, 1.3
- RedHat Ansible Inside: 1.3, 1.4
How to fix
Upgrade to a fixed version: Red Hat Ansible Automation Platform 2.6. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:19201
- https://access.redhat.com/errata/RHSA-2025:19221
- https://access.redhat.com/errata/RHSA-2025:23069
- https://access.redhat.com/errata/RHSA-2025:23131
- https://access.redhat.com/security/cve/CVE-2025-9907
- https://bugzilla.redhat.com/show_bug.cgi?id=2392834
Get alerted when CVE-2025-9907 or the next vulnerability affects your stack