What’s Vulnerable › Vulnerabilities
CVE-2025-9909: Aap-gateway: improper path validation in gateway allows credential exfiltration
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-647
Description
A flaw was found in the Red Hat Ansible Automation Platform Gateway route creation component. This vulnerability allows credential theft via the creation of misleading routes using a double-slash (//) prefix in the gateway_path. A malicious or socially engineered administrator can configure a honey-pot route to intercept and exfiltrate user credentials, potentially maintaining persistent access or creating a backdoor even after their permissions are revoked.
Affected products
- Red Hat Ansible Automation Platform: before 2.6 — fixed in 2.6
- RedHat Ansible Developer: 1.2, 1.3
- RedHat Ansible Inside: 1.3, 1.4
How to fix
Upgrade to a fixed version: Red Hat Ansible Automation Platform 2.6. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:21768
- https://access.redhat.com/errata/RHSA-2025:21775
- https://access.redhat.com/errata/RHSA-2025:23069
- https://access.redhat.com/errata/RHSA-2025:23131
- https://access.redhat.com/security/cve/CVE-2025-9909
- https://bugzilla.redhat.com/show_bug.cgi?id=2392836
Get alerted when CVE-2025-9909 or the next vulnerability affects your stack