What’s Vulnerable › Vulnerabilities
CVE-2025-9910
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-11 · updated 2026-10-19
- Weakness: CWE-79
Description
Versions of the package jsondiffpatch before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via HtmlFormatter::nodeBegin. An attacker can inject malicious scripts into HTML payloads that may lead to code execution if untrusted payloads were used as source for the diff, and the result renderer using the built-in html formatter on a private website.
Affected products
- jsondiffpatch: before 0.7.2 — fixed in 0.7.2
- org.webjars.bower:jsondiffpatch: all versions
- org.webjars.npm:jsondiffpatch: all versions
How to fix
Upgrade to a fixed version: jsondiffpatch 0.7.2. Check the vendor advisory for mitigations.
References
- https://benjamine.github.io/jsondiffpatch/index.html
- https://github.com/benjamine/jsondiffpatch/commit/0e374b5dd8d7879b329a9fc18affbd46ad50dd14
- https://github.com/benjamine/jsondiffpatch/issues/383
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-12549277
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-12549276
- https://security.snyk.io/vuln/SNYK-JS-JSONDIFFPATCH-10369031
Get alerted when CVE-2025-9910 or the next vulnerability affects your stack