What’s Vulnerable › Vulnerabilities
CVE-2025-9957: Incorrect Authorization in GitLab
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-10-14
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.2 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that under certain conditions could have allowed an authenticated user with project owner permissions to bypass group fork prevention settings due to improper authorization checks.
Affected products
- GitLab: from 11.2.0 before 18.9.6; from 18.10.0 before 18.10.4; 18.11.0 — fixed in 18.10.4, 18.9.6
How to fix
Upgrade to a fixed version: GitLab 18.10.4, 18.9.6. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/04/22/patch-release-gitlab-18-11-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/567781
- https://hackerone.com/reports/3275222
Get alerted when CVE-2025-9957 or the next vulnerability affects your stack