What’s Vulnerable › Vulnerabilities

CVE-2025-9958: Insertion of Sensitive Information Into Sent Data in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 14.10 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1, that could have allowed Guest users to access sensitive information stored in virtual registry configurations.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.2.7, 18.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-9958 or the next vulnerability affects your stack