What’s Vulnerable › Vulnerabilities
CVE-2025-9961: Authenticated RCE by CWMP binary
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-06 · updated 2026-09-26
- Weakness: CWE-120
Description
An authenticated attacker may remotely execute arbitrary code via the CWMP binary on the devices AX10 and AX1500. The exploit can only be conducted via a Man-In-The-Middle (MITM) attack. This issue affects AX10 V1/V1.2/V2/V2.6/V3/V3.6: before 1.2.1; AX1500 V1/V1.20/V1.26/V1.60/V1.80/V2.60/V3.6: before 1.3.11.
Affected products
- TP-Link Systems Inc. AX10 V1/V1.2/V2/V2.6/V3/V3.6: before 1.2.1 — fixed in 1.2.1
- TP-Link Systems Inc. AX1500 V1/V1.20/V1.26/V1.60/V1.80/V2.60/V3.6: before 1.3.11 — fixed in 1.3.11
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. AX10 V1/V1.2/V2/V2.6/V3/V3.6 1.2.1; TP-Link Systems Inc. AX1500 V1/V1.20/V1.26/V1.60/V1.80/V2.60/V3.6 1.3.11. Check the vendor advisory for mitigations.
References
- https://blog.byteray.co.uk/zero-day-alert-automated-discovery-of-critical-cwmp-stack-overflow-in-tp-link-routers-0bc495a08679
- https://www.tp-link.com/us/support/download/archer-ax10/
- https://www.tp-link.com/us/support/download/archer-ax1500/
- https://www.tp-link.com/us/support/faq/4647/
Get alerted when CVE-2025-9961 or the next vulnerability affects your stack