What’s Vulnerable › Vulnerabilities
CVE-2025-9978: Jeg Elementor Kit < 2.7.0 - Author+ Stored XSS
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-24 · updated 2026-10-08
- Weakness: CWE-79
Description
The Jeg Kit for Elementor WordPress plugin before 2.7.0 does not sanitize SVG file contents when uploaded via xmlrpc.php, leading to a cross site scripting vulnerability.
Affected products
- Jeg Kit for Elementor: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: Jeg Kit for Elementor 2.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-9978 or the next vulnerability affects your stack