What’s Vulnerable › Vulnerabilities
CVE-2026-0228: PAN-OS: Improper Validation of Terminal Server Agent Certificate
- Severity: low (CVSS 1.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-11 · updated 2026-06-17
- Weakness: CWE-295
Description
An improper certificate validation vulnerability in PAN-OS allows users to connect Terminal Server Agents on Windows to PAN-OS using expired certificates even if the PAN-OS configuration would not normally permit them to do so.
Affected products
- Palo Alto Networks PAN-OS: from 11.2.0 before 11.2.8; from 11.1.0 before 11.1.11; from 10.2.0 before 10.2.17 — fixed in 10.2.17, 11.1.11, 11.2.8
- Palo Alto Networks Prisma Access: from 10.2.0 before 10.2.10-h28 — fixed in 10.2.10-h28
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.2.17, 11.1.11, 11.2.8; Palo Alto Networks Prisma Access 10.2.10-h28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-0228 or the next vulnerability affects your stack