What’s Vulnerable › Vulnerabilities
CVE-2026-0250: GlobalProtect App: Buffer Overflow Vulnerability during connection to Portal or Gateway
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-787
Description
A buffer overflow vulnerability exists in the Palo Alto Networks GlobalProtect™ app that enables a man in the middle attacker to disrupt system processes and potentially execute arbitrary code with SYSTEM privileges. This vulnerability is triggered during the processing of requests and responses exchanged between Portal and Gateway. The GlobalProtect app on iOS is not affected.
Affected products
- Palo Alto Networks GlobalProtect App: from 6.0.0 before 6.0.12; from 6.0.0 before 6.0.13; from 6.0.0 before 6.0.15; from 6.1.0 before 6.1.14; from 6.2.0 before 6.2.8; from 6.3.0 before 6.3.3 — fixed in 6.0.12, 6.0.13, 6.0.15, 6.1.14, 6.2.8, 6.3.3
- Palo Alto Networks GlobalProtect App: from 6.3.0 before 6.3.3-h9 (6.3.3-999); from 6.2.0 before 6.2.8-h10 (6.2.8-948) — fixed in 6.3.3-h9 (6.3.3-999), 6.2.8-h10 (6.2.8-948)
- Palo Alto Networks GlobalProtect UWP App: from 6.3 before 6.3.3-h10 — fixed in 6.3.3-h10
How to fix
Upgrade to a fixed version: Palo Alto Networks GlobalProtect App 6.0.12, 6.0.13, 6.0.15, 6.1.14; Palo Alto Networks GlobalProtect App 6.3.3-h9 (6.3.3-999), 6.2.8-h10 (6.2.8-948); Palo Alto Networks GlobalProtect UWP App 6.3.3-h10. Check the vendor advisory for mitigations.
In the news
References
Get alerted when CVE-2026-0250 or the next vulnerability affects your stack