What’s Vulnerable › Vulnerabilities
CVE-2026-0259: WildFire WF-500 and WF-500-B: Arbitrary File Read and Delete Vulnerability in WildFire Appliance (WF-500, WF-500-B)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-73
Description
An arbitrary File Read and Delete Vulnerability in Palo Alto Networks WildFire® WF-500 and WF-500-B appliances enables users to read sensitive information and delete arbitrary files. This vulnerability affects WF-500 and WF-500-B appliances running in the default non-FIPS configuration mode. The WildFire Appliance (WF-500, WF-500-B) software update is now available to customers that use the WildFire Appliance (WF-500, WF-500-B) for on-premise sandboxing. Please note that customers using the WildFire Public cloud service are NOT impacted by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: before 10.2.7; from 10.2.8 before 10.2.10; from 10.2.11 before 10.2.13; from 10.2.14 before 10.2.16; from 11.1.0 before 11.1.4; from 11.1.5 before 11.1.6 — fixed in 10.2.7, 10.2.10, 10.2.13, 10.2.16, 11.1.4, 11.1.6
- Palo Alto Networks WildFire WF-500 and WF-500-B: from 12.1.0 before 12.1.7, 12.1.4-h5; from 11.2.0 before 11.2.11,11.2.7-h7; from 11.1.0 before 11.1.13,11.1.10-h8; from 10.2.0 before 10.2.18-h6, 10.2.16-h7, 10.2.13-h21, 10.2.10-h36, 10.2.7-h34 — fixed in 12.1.7, 12.1.4-h5, 12.1.4-h5, 12.1.7, 11.2.11, 11.2.7-h7
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.2.7, 10.2.10, 10.2.13, 10.2.16; Palo Alto Networks WildFire WF-500 and WF-500-B 12.1.7, 12.1.4-h5, 12.1.4-h5, 12.1.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-0259 or the next vulnerability affects your stack