What’s Vulnerable › Vulnerabilities
CVE-2026-0266: PAN-OS: Stored Cross-Site Scripting (XSS) Vulnerability in the Web Interface
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-10-15
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS® software enables a malicious authenticated administrator to store a JavaScript payload using the web interface. This issue is applicable to PAN-OS software on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Cloud NGFW and Prisma® Access are not affected by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: from 10.2.0 before 11.1.14; from 11.2.0 before 11.2.11; from 12.1.0 before 12.1.5 — fixed in 11.1.14, 11.2.11, 12.1.5
- Palo Alto Networks PAN-OS: from 12.1.0 before 12.1.5; from 11.2.0 before 11.2.11; from 11.1.0 before 11.1.14; 10.2.0 — fixed in 12.1.5, 11.2.11, 11.1.14
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 11.1.14, 11.2.11, 12.1.5; Palo Alto Networks PAN-OS 12.1.5, 11.2.11, 11.1.14. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2026-0266
- https://cert-portal.siemens.com/productcert/html/ssa-104023.html
Get alerted when CVE-2026-0266 or the next vulnerability affects your stack