What’s Vulnerable › Vulnerabilities
CVE-2026-0316: PAN-OS: Stored Cross-Site Scripting (XSS) Vulnerability
- Severity: low (CVSS 1.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS® software enables a malicious authenticated administrator to store or execute a JavaScript payload using the web interface. The security risk posed by this issue is minimized when the management interface is restricted to only trusted internal IP addresses according to our recommended best practice deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 . This issue is applicable to PAN-OS® software on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Cloud NGFW and Prisma® Access are not affected by these vulnerabilities.
Affected products
- Palo Alto Networks PAN-OS: from 12.2.0 before 12.2.4; from 12.1.0 before 12.1.10-h2; from 11.2.0 before 11.2.16; from 11.1.0 before 11.1.16-h3 — fixed in 11.1.16-h3, 11.2.16, 12.1.10-h2, 12.2.4
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 11.1.16-h3, 11.2.16, 12.1.10-h2, 12.2.4. Check the vendor advisory for mitigations.
In the news
References
Get alerted when CVE-2026-0316 or the next vulnerability affects your stack