What’s Vulnerable › Vulnerabilities
CVE-2026-0320: PAN-OS: Authenticated Admin Command Injection Vulnerability
- Severity: medium (CVSS 6.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-78
Description
A command injection vulnerability in Palo Alto Networks PAN-OS® software enables an authenticated administrator to bypass system restrictions and run arbitrary commands as a root user. To be able to exploit this issue, the user must have access to the PAN-OS management interface. The security risk posed by this issue is significantly minimized by restricting access to the management interface to only trusted internal IP addresses according to our recommended best practice deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 . This issue is applicable to PAN-OS software on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Cloud NGFW and Prisma® Access are not affected by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: from 12.2.0 before 12.2.4; from 12.1.0 before 12.1.10-h2; from 11.2.0 before 11.2.16; from 11.1.0 before 11.1.16-h3; from 10.2.0 before 10.2.18-h12 — fixed in 10.2.18-h12, 11.1.16-h3, 11.2.16, 12.1.10-h2, 12.2.4
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.2.18-h12, 11.1.16-h3, 11.2.16, 12.1.10-h2. Check the vendor advisory for mitigations.
In the news
References
Get alerted when CVE-2026-0320 or the next vulnerability affects your stack