What’s Vulnerable › Vulnerabilities
CVE-2026-0322: Palo Alto Networks PAN-OS Code Injection Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-10-14
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-94
Description
A remote code execution (RCE) vulnerability in the management interface of Palo Alto Networks PAN-OS® software enables an authenticated attacker with network access to execute arbitrary code with root privileges on the firewall. The security risk posed by this issue is minimized by restricting access to the management interface to only trusted internal IP addresses according to our recommended best practice deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 . This issue is applicable to PAN-OS software on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Cloud NGFW and Prisma® Access are not impacted by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: before 10.2.0; from 12.2.0 before 12.2.4; 10.2.7, 10.2.7-h1, 10.2.7-h12, 10.2.7-h16, 10.2.7-h18, 10.2.7-h19 (+243) — fixed in 10.2.0, 12.2.4
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.2.0, 12.2.4. Check the vendor advisory for mitigations.
In the news
References
- https://security.paloaltonetworks.com/CVE-2026-0322
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-0322
Get alerted when CVE-2026-0322 or the next vulnerability affects your stack