What’s Vulnerable › Vulnerabilities
CVE-2026-0393: CODESYS Visualization - Insufficiently Protected Credentials
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-21 · updated 2026-07-23
- Weakness: CWE-522
Description
The affected product may expose credentials remotely between low privileged visualization users during concurrent login operations due to insufficient isolation of authentication data. The vulnerability affects only login operations within an active visualization session.
Affected products
- CODESYS Visualization: from 1.0.0.0 before 4.10.0.0 — fixed in 4.10.0.0
How to fix
Upgrade to a fixed version: CODESYS Visualization 4.10.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-0393 or the next vulnerability affects your stack