What’s Vulnerable › Vulnerabilities
CVE-2026-0406: Insufficient input validation in NETGEAR Nighthawk router XR1000v2
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-06-17
- Weakness: CWE-20
Description
An insufficient input validation vulnerability in the NETGEAR XR1000v2 allows attackers connected to the router's LAN to execute OS command injections.
Affected products
- NETGEAR XR1000v2: before 1.1.2.34 — fixed in 1.1.2.34
How to fix
Upgrade to a fixed version: NETGEAR XR1000v2 1.1.2.34. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000070442/January-2026-NETGEAR-Security-Advisory
- https://www.netgear.com/support/product/xr1000v2
Get alerted when CVE-2026-0406 or the next vulnerability affects your stack