What’s Vulnerable › Vulnerabilities
CVE-2026-0528: Improper Input Validation in Metricbeat Leading to Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-06-17
- Weakness: CWE-129
Description
Improper Validation of Array Index (CWE-129) exists in Metricbeat can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed payloads sent to the Graphite server metricset or Zookeeper server metricset. Additionally, Improper Input Validation (CWE-20) exists in the Prometheus helper module that can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed metric data.
Affected products
- Kibana: from 7.0.0 before 7.17.29; from 8.0.0 before 8.19.10; from 9.0.0 before 9.1.10; from 9.2.0 before 9.2.4 — fixed in 7.17.29, 8.19.10, 9.1.10, 9.2.4
How to fix
Upgrade to a fixed version: Kibana 7.17.29, 8.19.10, 9.1.10, 9.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-0528 or the next vulnerability affects your stack