What’s Vulnerable › Vulnerabilities
CVE-2026-0704
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-22
Description
In affected version of Octopus Deploy it was possible to remove files and/or contents of files on the host using an API endpoint. The field lacked validation which could potentially result in ways to circumvent expected workflows.
Affected products
- Octopus Deploy Octopus Server: from 2023.1.4189 before 2025.3.14715 — fixed in 2025.3.14715
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2025.3.14715. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-0704 or the next vulnerability affects your stack