What’s Vulnerable › Vulnerabilities

CVE-2026-0835

Description

IBM Sterling B2B Integrator and IBM Sterling File Gateway 6.1.0.0 through 6.1.2.7_2, 6.2.0.0 through 6.2.0.5_1, 6.2.1.0 through 6.2.1.1_1, and 6.2.2.0 are vulnerable to cross-site scripting. This vulnerability allows an authenticated user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.

Affected products

How to fix

Upgrade to a fixed version: IBM Sterling B2B Integrator 6.1.2.8, 6.2.0.5_2, 6.2.1.1_2; IBM Sterling File Gateway 6.1.2.8, 6.2.0.5_2, 6.2.1.1_2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-0835 or the next vulnerability affects your stack