What’s Vulnerable › Vulnerabilities
CVE-2026-0858
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package net.sourceforge.plantuml:plantuml before 1.2026.0 are vulnerable to Stored XSS due to insufficient sanitization of interactive attributes in GraphViz diagrams. As a result, a crafted PlantUML diagram can inject malicious JavaScript into generated SVG output, leading to arbitrary script execution in the context of applications that render the SVG.
Affected products
- net.sourceforge.plantuml:plantuml: before 1.2026.0 — fixed in 1.2026.0
How to fix
Upgrade to a fixed version: net.sourceforge.plantuml:plantuml 1.2026.0. Check the vendor advisory for mitigations.
References
- https://github.com/plantuml/plantuml/commit/6826315db092d2e432aeab1a0894e08017c6e4bd
- https://github.com/plantuml/plantuml/releases/tag/v1.2026.0
- https://security.snyk.io/vuln/SNYK-JAVA-NETSOURCEFORGEPLANTUML-14552230
Get alerted when CVE-2026-0858 or the next vulnerability affects your stack